Skip to content

FireFox 3.5 sur eee pc (Xandros)

Firefox 3.5.1 opérationnel
Pour installer Firefox 3.5 sur un eee-pc sous Linux Xandros, il faut tout d'abord, récupérer FireFox sur le site officiel. On supposera que le fichier est enregistré dans le répertoire racine de l'utilisateur "user".

Le reste des opération doit se faire sous l'utilisateur "root". Le plus simple étant, après avoir ouvert un terminal, de faire sudo bash.
Il faut ensuite supprimer la version précédente de Firefox :

cd /opt
mv firefox firefox.old


Il faut ensuite installer la nouvelle version :

bzip2 -dc /home/user/firefox-3.5.1.tar.bz2 | tar xf -

Puis copier le raccourci qui permet l'affichage dans l'interface Xandros AsusLauncher :

cd firefox
cp ../firefox.old/firefox.desktop .


Il ne reste plus qu'à peaufiner les réglages de Firefox (pour ma part, j'ai mis le cache disque à 0, en laissant le cache mémoire faire son ½uvre et j'ai installé une version compatible du dictionnaire français, disponible à l'adresse https://addons.mozilla.org/en-US/firefox/addons/versions/3066).

Rétroliens

Pas de rétroliens

Commentaires

Afficher les commentaires en Vue non groupée | Vue groupée

Didier Bretin sur :

Bonjour,

J'ai un problème, Firefox me dit que je n'ai pas la bonne version de GTK+. Comment faire pour mettre à jour cette librairie ?

Cordialement.

gluon sur :

Même problème. J'ai installé Firefox 3.6.2 par apt-get, mais quand j'essaye de le lancer, il se plaint de ne pas avoir la bonne version de Gtk (un message étrange qui est qqchose comme 'vous avez la version 2.8 et il vous faudrait une 2.01 ou supérieur" (!).
Le problème est que j'ignore le nom des paquetages gtk de xandros à télécharger.
Que faire ?

Sébastien sur :

j'utilise directement la version téléchargeable sur le site de firefox et je ne passe pas par apt-get.

pierre sur :

alors moi je n'ai pas utilisé mon eeepc depuis 1 an et quelque, j'ai la version2 de firefox... :p oui je sais bon...

et alors c'est un merdier pas possible, je n'ai pas le droit de virer firefox v2 avec les commande mv...etc ca me dit que je n'ai pas la permission alors que je suis le seul utilisateur et qu'il n'y a pas d'autres sessions ou choses de cet ordre

du coup n'étant pas tres calé en informatique ca me bloque totalement, je ne peux plus lire de video, mon navigateur ne les prends pas en charge.

je n'arrive pas non plus a installer la version 3.6, rien ne marche, je tourne en rond et je commence a etre vraiment fatigué...

quelqu'un peu m'aider? reellement merci a celui qui m'apportera la serenite.

bonne nuit et a tres vite.
pierrot

Anonyme sur :

Pierre, pour effectuer des tâches d'administration sous une distribution Linux de ce type les commandes doivent être précédées de sudo.

Par exemple pour renommer un fichier truc en machin, tu fais :
sudo mv truc machin
etc.
Pour faire une série de commandes de ce type tu peux passer carrément en root par un
sudo su
tu seras ainsi en root et tu pourras lancer une série de commandes sans avoir à retaper sudo perpétuellement.

Vincent SABY sur :

je n'y connais rien et j'ai le même problème, par contre j'ai repéré /opt/mozilla-1.9.1/embedding/browser/gtk c'est peut-être une piste.
voir les releases de mozilla ici:
http://hg.mozilla.org/releases/
il y a mozilla-1.9.2 qui correspond à la version 3.6 de firefox...

Ajouter un commentaire

Marquer un texte en gras: *mot*, souligner un texte: _mot_.
Les smilies standard comme :-) et ;-) sont convertis en images.
:'(  :-)  :-|  :-O  :-(  8-)  :-D  :-P  ;-) 
Les adresses Email ne sont pas affichées, et sont seulement utilisées pour la communication.

Pour éviter le spam par des robits automatisés (spambots), merci d'entrer les caractères que vous voyez dans l'image ci-dessous dans le champ de fomulaire prévu à cet effet. Assurez-vous que votre navigateur gère et accepte les cookies, sinon votre commentaire ne pourra pas être enregistré.
CAPTCHA

Form options